using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"id=""(entryID..)""";
string substitution = @"$(""#$1"");";
string input = @"id=""entryID23""
id=""entryID76""
id=""entryID33""
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}