# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\b(?:\p{Lu}\.){2,})|[^0-9\p{L}]/$1 /gu;t' <<< "F.B.I.Federal.Bureau.of.Investigation"