using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\b(?:\p{Lu}\.){2,})|[^0-9\p{L}]";
string substitution = @"$1 ";
string input = @"F.B.I.Federal.Bureau.of.Investigation";
RegexOptions options = RegexOptions.CultureInvariant;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}