use strict;
my $str = 'F.B.I.Federal.Bureau.of.Investigation';
my $regex = qr/(\b(?:\p{Lu}\.){2,})|[^0-9\p{L}]/up;
my $subst = '$1 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";