$re = '/(\b(?:\p{Lu}\.){2,})|[^0-9\p{L}]/u';
$str = 'F.B.I.Federal.Bureau.of.Investigation';
$subst = "$1 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;