package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\b(?:\p{Lu}\.){2,})|[^0-9\p{L}]`)
var str = `F.B.I.Federal.Bureau.of.Investigation`
var substitution = "$1 "
fmt.Println(re.ReplaceAllString(str, substitution))
}