re = /(\b(?:\p{Lu}\.){2,})|[^0-9\p{L}]/
str = 'F.B.I.Federal.Bureau.of.Investigation'
subst = '$1 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result