// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)(\b(?:\p{Lu}\.){2,})|[^0-9\p{L}]").unwrap();
let string = "F.B.I.Federal.Bureau.of.Investigation";
let substitution = "$1 ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}