# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?=(?!\bTODO\b)*?;).*)((?=.*?\bTODO\b).*)[^\n]/$1"address": /g;t' <<< "; comment that contains TODO - correct
TODO := 5 ; comment that isn't valid t-o-d-o
; regular comment"