#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "((?=(?!\bTODO\b)*?;).*)((?=.*?\bTODO\b).*)[^\n]"
Local $sString = "; comment that contains TODO - correct" & @CRLF & _
"TODO := 5 ; comment that isn't valid t-o-d-o" & @CRLF & _
"; regular comment"
Local $sSubst = "$1"address": "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)