import Foundation
let pattern = #"((?=(?!\bTODO\b)*?;).*)((?=.*?\bTODO\b).*)[^\n]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
; comment that contains TODO - correct
TODO := 5 ; comment that isn't valid t-o-d-o
; regular comment
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"address": "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)