import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?=(?!\\bTODO\\b)*?;).*)((?=.*?\\bTODO\\b).*)[^\\n]";
final String string = "; comment that contains TODO - correct\n"
+ "TODO := 5 ; comment that isn't valid t-o-d-o\n"
+ "; regular comment";
final String subst = "$1\"address\": ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}