$re = '/((?=(?!\bTODO\b)*?;).*)((?=.*?\bTODO\b).*)[^\n]/';
$str = '; comment that contains TODO - correct
TODO := 5 ; comment that isn\'t valid t-o-d-o
; regular comment';
$subst = "$1\"address\": ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;