use strict;
my $str = '; comment that contains TODO - correct
TODO := 5 ; comment that isn\'t valid t-o-d-o
; regular comment';
my $regex = qr/((?=(?!\bTODO\b)*?;).*)((?=.*?\bTODO\b).*)[^\n]/p;
my $subst = '$1"address": ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";