using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?=(?!\bTODO\b)*?;).*)((?=.*?\bTODO\b).*)[^\n]";
string substitution = @"$1""address"": ";
string input = @"; comment that contains TODO - correct
TODO := 5 ; comment that isn't valid t-o-d-o
; regular comment";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}