re = /((?=(?!\bTODO\b)*?;).*)((?=.*?\bTODO\b).*)[^\n]/
str = '; comment that contains TODO - correct
TODO := 5 ; comment that isn\'t valid t-o-d-o
; regular comment'
subst = '$1"address": '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result