using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\ba[^ex]*?a\b";
string substitution = @"!";
string input = @"Есть исходник, не совсем удобный:
""aba aea aca aza axa a-a a#a""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}