const regex = /\ba[^ex]*?a\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\ba[^ex]*?a\\b', 'gm')
const str = `Есть исходник, не совсем удобный:
"aba aea aca aza axa a-a a#a"`;
const subst = `!`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);