import re
regex = re.compile(r"\ba[^ex]*?a\b", flags=re.MULTILINE)
test_str = ("Есть исходник, не совсем удобный:\n"
"\"aba aea aca aza axa a-a a#a\"")
subst = "!"
result = regex.sub(subst, test_str)
if result:
print(result)