$re = '/\ba[^ex]*?a\b/m';
$str = 'Есть исходник, не совсем удобный:
"aba aea aca aza axa a-a a#a"';
$subst = "!";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;