re = /\ba[^ex]*?a\b/m
str = 'Есть исходник, не совсем удобный:
"aba aea aca aza axa a-a a#a"'
subst = '!'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result