import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\{window\\.location\\.(.+?)\\}\\}";
final String string = "1. this isa (test)\n"
+ "2. tis is a {{test}}\n"
+ "3. thisis a {{instance.test}}\n"
+ "4. thisis a {{instance.something}}\n"
+ "5. this is a {{window.location.hostname}} {{window.location.protocol}} ";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}