import re
regex = re.compile(r"\{\{window\.location\.(.+?)\}\}", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("1. this isa (test)\n"
"2. tis is a {{test}}\n"
"3. thisis a {{instance.test}}\n"
"4. thisis a {{instance.something}}\n"
"5. this is a {{window.location.hostname}} {{window.location.protocol}} ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")