$re = '/\{\{window\.location\.(.+?)\}\}/im';
$str = '1. this isa (test)
2. tis is a {{test}}
3. thisis a {{instance.test}}
4. thisis a {{instance.something}}
5. this is a {{window.location.hostname}} {{window.location.protocol}} ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);