const regex = /\{\{window\.location\.(.+?)\}\}/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{\\{window\\.location\\.(.+?)\\}\\}', 'gim')
const str = `1. this isa (test)
2. tis is a {{test}}
3. thisis a {{instance.test}}
4. thisis a {{instance.something}}
5. this is a {{window.location.hostname}} {{window.location.protocol}} `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}