using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:(?:jam)+|jam\h*\d*)\b";
string input = @"Custard 1
Custard 1 jam
stuff
stuff jam
jam 2
2 jam 47
Custard 1 jam jam2
jam jam
Custard 1 jam jam jam
jamjamjam
jam
14 fluorojam.
pajama.
jammer
jamjamjamjam";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}