import Foundation
let pattern = #"\b(?:(?:jam)+|jam\h*\d*)\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
Custard 1
Custard 1 jam
stuff
stuff jam
jam 2
2 jam 47
Custard 1 jam jam2
jam jam
Custard 1 jam jam jam
jamjamjam
jam
14 fluorojam.
pajama.
jammer
jamjamjamjam
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)