import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:(?:jam)+|jam\\h*\\d*)\\b";
final String string = "Custard 1\n"
+ "Custard 1 jam\n"
+ "stuff\n"
+ "stuff jam\n"
+ "jam 2\n"
+ "2 jam 47\n"
+ "Custard 1 jam jam2\n"
+ "jam jam\n"
+ "Custard 1 jam jam jam\n"
+ "jamjamjam\n"
+ " jam\n"
+ "14 fluorojam.\n"
+ "pajama.\n"
+ "jammer\n"
+ "jamjamjamjam";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}