# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(?:(?:jam)+|jam\h*\d*)\b"
test_str = ("Custard 1\n"
"Custard 1 jam\n"
"stuff\n"
"stuff jam\n"
"jam 2\n"
"2 jam 47\n"
"Custard 1 jam jam2\n"
"jam jam\n"
"Custard 1 jam jam jam\n"
"jamjamjam\n"
" jam\n"
"14 fluorojam.\n"
"pajama.\n"
"jammer\n"
"jamjamjamjam")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.