package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\b(?:(?:jam)+|jam\h*\d*)\b`)
var str = `Custard 1
Custard 1 jam
stuff
stuff jam
jam 2
2 jam 47
Custard 1 jam jam2
jam jam
Custard 1 jam jam jam
jamjamjam
jam
14 fluorojam.
pajama.
jammer
jamjamjamjam`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}