re = /\b(?:(?:jam)+|jam\h*\d*)\b/mi
str = 'Custard 1
Custard 1 jam
stuff
stuff jam
jam 2
2 jam 47
Custard 1 jam jam2
jam jam
Custard 1 jam jam jam
jamjamjam
jam
14 fluorojam.
pajama.
jammer
jamjamjamjam'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end