const regex = /\b(?:(?:jam)+|jam\h*\d*)\b/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:(?:jam)+|jam\\h*\\d*)\\b', 'gmi')
const str = `Custard 1
Custard 1 jam
stuff
stuff jam
jam 2
2 jam 47
Custard 1 jam jam2
jam jam
Custard 1 jam jam jam
jamjamjam
jam
14 fluorojam.
pajama.
jammer
jamjamjamjam`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}