// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)\b(?:(?:jam)+|jam\h*\d*)\b").unwrap();
let string = "Custard 1
Custard 1 jam
stuff
stuff jam
jam 2
2 jam 47
Custard 1 jam jam2
jam jam
Custard 1 jam jam jam
jamjamjam
jam
14 fluorojam.
pajama.
jammer
jamjamjamjam";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}