#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "001("[^"]*")*([^@]*)*@"
Local $sString = "001@001Semper exitialis "fkjfk"cum subsidia ductor notissimus subsidia et ductor cui@001Annonas et "@"et contumaciter conspectum@001Quo amicissimos ad uxoriae certamen pecuniae tamen ="@" dirimi conte"klkj @"ntione nullam.@001hsjh@"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")