re = /001("[^"]*")*([^@]*)*@/
str = '001@001Semper exitialis "fkjfk"cum subsidia ductor notissimus subsidia et ductor cui@001Annonas et "@"et contumaciter conspectum@001Quo amicissimos ad uxoriae certamen pecuniae tamen ="@" dirimi conte"klkj @"ntione nullam.@001hsjh@'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end