$re = '/001("[^"]*")*([^@]*)*@/';
$str = '001@001Semper exitialis "fkjfk"cum subsidia ductor notissimus subsidia et ductor cui@001Annonas et "@"et contumaciter conspectum@001Quo amicissimos ad uxoriae certamen pecuniae tamen ="@" dirimi conte"klkj @"ntione nullam.@001hsjh@';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);