import Foundation
let pattern = #"001("[^"]*")*([^@]*)*@"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"001@001Semper exitialis "fkjfk"cum subsidia ductor notissimus subsidia et ductor cui@001Annonas et "@"et contumaciter conspectum@001Quo amicissimos ad uxoriae certamen pecuniae tamen ="@" dirimi conte"klkj @"ntione nullam.@001hsjh@"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)