package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`001("[^"]*")*([^@]*)*@`)
var str = `001@001Semper exitialis "fkjfk"cum subsidia ductor notissimus subsidia et ductor cui@001Annonas et "@"et contumaciter conspectum@001Quo amicissimos ad uxoriae certamen pecuniae tamen ="@" dirimi conte"klkj @"ntione nullam.@001hsjh@`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}