using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"001(""[^""]*"")*([^@]*)*@";
string input = @"001@001Semper exitialis ""fkjfk""cum subsidia ductor notissimus subsidia et ductor cui@001Annonas et ""@""et contumaciter conspectum@001Quo amicissimos ad uxoriae certamen pecuniae tamen =""@"" dirimi conte""klkj @""ntione nullam.@001hsjh@";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}