import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "001(\"[^\"]*\")*([^@]*)*@";
final String string = "001@001Semper exitialis \"fkjfk\"cum subsidia ductor notissimus subsidia et ductor cui@001Annonas et \"@\"et contumaciter conspectum@001Quo amicissimos ad uxoriae certamen pecuniae tamen =\"@\" dirimi conte\"klkj @\"ntione nullam.@001hsjh@";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}