package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\bhttps?\:[^ {}\[\]]+?\.jpg\b)`)
var str = `<option value="https://cdn.images.com/storage/The science/7456t5435435_d6186a5f10.png"
>
Flask
</option>
<option value="https://cdn.images.com/storage/The science/54645yt654_d6186a5f10.jpg"
>
Flask
</option>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}