use strict;
my $str = '<option value="https://cdn.images.com/storage/The science/7456t5435435_d6186a5f10.png"
>
Flask
</option>
<option value="https://cdn.images.com/storage/The science/54645yt654_d6186a5f10.jpg"
>
Flask
</option>
';
my $regex = qr/(\bhttps?\:[^ {}\[\]]+?\.jpg\b)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}