// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\bhttps?\:[^ {}\[\]]+?\.jpg\b)").unwrap();
let string = "<option value=\"https://cdn.images.com/storage/The science/7456t5435435_d6186a5f10.png\"
>
Flask
</option>
<option value=\"https://cdn.images.com/storage/The science/54645yt654_d6186a5f10.jpg\"
>
Flask
</option>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}