re = /(\bhttps?\:[^ {}\[\]]+?\.jpg\b)/m
str = '<option value="https://cdn.images.com/storage/The science/7456t5435435_d6186a5f10.png"
>
Flask
</option>
<option value="https://cdn.images.com/storage/The science/54645yt654_d6186a5f10.jpg"
>
Flask
</option>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end