import re
regex = re.compile(r"(\bhttps?\:[^ {}\[\]]+?\.jpg\b)", flags=re.MULTILINE)
test_str = ("<option value=\"https://cdn.images.com/storage/The science/7456t5435435_d6186a5f10.png\"\n"
" >\n"
" Flask\n"
" </option>\n"
" <option value=\"https://cdn.images.com/storage/The science/54645yt654_d6186a5f10.jpg\"\n"
" >\n"
" Flask\n"
" </option>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")