import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\bhttps?\\:[^ \\{\\}\\[\\]]+?\\.jpg\\b)";
final String string = "<option value=\"https://cdn.images.com/storage/The science/7456t5435435_d6186a5f10.png\"\n"
+ " >\n"
+ " Flask\n"
+ " </option>\n"
+ " <option value=\"https://cdn.images.com/storage/The science/54645yt654_d6186a5f10.jpg\"\n"
+ " >\n"
+ " Flask\n"
+ " </option>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}