#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "%%name%%"
Local $sString = "Welcome, %%name%%!" & @CRLF & _
"Congratulations!"
Local $sSubst = "\$1ndy"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)