package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`%%name%%`)
var str = `Welcome, %%name%%!
Congratulations!`
var substitution = "\$1ndy"
fmt.Println(re.ReplaceAllString(str, substitution))
}