using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"%%name%%";
string substitution = @"\$1ndy";
string input = @"Welcome, %%name%%!
Congratulations!";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}