use strict;
my $str = 'Welcome, %%name%%!
Congratulations!';
my $regex = qr/%%name%%/p;
my $subst = '\\$1ndy';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";